Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
Mapserver dla opornych cz.2
20-02-2015, 01:59 PM (Ten post był ostatnio modyfikowany: 20-02-2015 02:01 PM przez Bles.)
Post: #1
Mapserver dla opornych cz.2
Witam ponownie. I znowu proszę o podpowiedź. Otóż mam serwer VPS z Debianem 7 na pokładzie w formie 32 bit. I chciałbym uruchomić Mapserver na potrzeby geoportalu. Jest tam repozytorium pakietów do zainstalowania (a tych pakietów różnych to tam 32000 :-) ) no i pomiędzy nimi znalazłem takie związane z Mapsever - do zainstalowania. Oto i one:

mapserver-bin

mapserver-doc

cgi-mapserver

qgis-mapserver

aby było więcej szczegółów - zamieszczam do posta PrtSc.

Dotarłem też do informacji że każdy z tych powyższych pakietów jest powiązany z bibliotekami - tu przykładowy link https://packages.debian.org/wheezy/mapserver-bin

[undefined=undefined]Oto moje pytanie:
na zdjęciu widać iż obok każdego pakietu jest okienko, zaznaczam w nim "ptaszka" i daję komendę INSTALUJ.
Czy to wystarczy aby Mapserver stał się już silnikiem dla Geoportalu ?[/undefined]
Jakieś to takie zbyt proste :-)
Czy wcześniej będę musiał w podobny sposób poinstalować biblioteki dla każdego z pakietów (wykaz w powyższym linku) ?
Bazą miałby być PostgeSQL z nakładką PostGis - czy mam ją skonfigurować przed instalacją Mapserver ?


Załączone pliki Miniatury
   
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
20-02-2015, 05:55 PM
Post: #2
RE: Mapserver dla opornych cz.2
Wydaje mi się, że instalacja samych pakietów mapservera powinna wystarczyć. Poczytaj coś w dokumentacji, może tam jest więcej napisane.
A co do baz danych, to kolejność instalacji i konfiguracji nie ma raczej wpływu.
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
26-02-2015, 06:09 PM
Post: #3
RE: Mapserver dla opornych cz.2
Przypadkiem znalazłem taki wpis:
https://dragons8mycat.wordpress.com/2014...xperience/

Może się przydać Wink
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
03-03-2015, 02:42 PM
Post: #4
RE: Mapserver dla opornych cz.2
Nie wiem, co dokładnie rozumiesz przez silnik dla geoportalu. Jeśli chcesz zainstalować sam serwer WMS, to masz na tej liście dwa do wyboru: w pakiecie cgi-mapserver znajduje się UMN Mapserver, zaś w pakiecie qgis-mapserver QGIS Server, przy czym ten drugi w archaicznej wersji. Obydwa są fajne Wink przy czym jeśli szukasz czegoś lekkiego i prostego, konfigurowanego w całości (włącznie ze stylami) ręcznie przez pliki konfiguracyjne, to UMN Mapserver jest świetny, natomiast QGIS Server to jest po prostu QGIS, tylko zamiast interfejsu graficznego (jak QGIS Desktop) ma interfejs WMS/WFS - czyli np. serwuje warstwy mapy, legendy i całe wydruki na podstawie projektu .qgs analogicznie jak desktopowy QGIS wyświetla je na ekranie. Bardzo to wygodne, bo nic nie trzeba konfigurować - wgrywasz projekt .qgs (byle utworzony w tej lub starszej - ew. niewiele nowszej wersji QGIS-a Desktop) do katalogu i śmiga. Tylko musisz pamiętać, że w tej wersji QGIS-a komponent serwerowy był jeszcze dość niedojrzałą nowinką, chociaż całkiem używalną. No i jak napisałem, nie wrzuć projektu z QGIS-a 2.8 do tego 1.7, bo wiele z niego nie zrozumie Wink

Postgis jest zupełnie niezależny od serwera WMS, więc nie ma znaczenia, czy zainstalujesz go wcześniej, czy później (a nawet w ogóle, jeśli warstwy będziesz miał np. w SpatiaLite czy - tfu tfu - szejpach Wink

Borys Jurgiel
Zespół Rozwojowy QGIS
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
18-05-2015, 10:26 AM
Post: #5
RE: Mapserver dla opornych cz.2
Witam ponownie - odświeżam temat instalacji - bo mapserver wygląda niezwykle profesjonalnie a tu na forum martwo. Doszedłem już jakiś czas temu, że nie może to być zwykły hosting do instalacji mapservera tylko dobrze jest mieś VPS. :-) No i trzeba zadeklarować jakiś system operacyjny. Zaryzykowałem i poszedłem w Debiana 7 - chociaż od dziecka jestem "windziarzem" - ale kiedyś trzeba było przekroczyć Rubikon - to już coś :-) a teraz instalowanie tam mapservera. Czy któryś z szanownych forumowiczów instalował może posługując się opisem z tej strony?
http://svn.pmapper.net/trac/wiki/MapServerInstall
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
25-05-2015, 12:30 AM
Post: #6
RE: Mapserver dla opornych cz.2
A próbowałeś zrobić wg tego poniżej i skorzystać z FastCGI dla Apache?
http://www.opendem.info/umn_mapserver.html

Nie wiem też czy konieczna jest kompilacja, bo z tego co widzę to paczki są gotowe, wystarczy wpisać
Kod:
sudo apt-get install mapserver-bin

albo właśnie
Kod:
sudo apt-get install cgi-mapserver
i reszta zależności powinna dociągnąć i zainstalować się sama (w tym sam mapserver-bin). Ale Debiana nie posiadam aktualnie, także nie mogę potwierdzić czy to działa (ale powinno)
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
Odpowiedz 


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Mapserver dla opornych Bles 9 41 042 22-03-2017 02:23 PM
Ostatni post: major9988

Skocz do: