Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
QGIS i WMS stworzony w Mapserver
01-06-2010, 18:31,
#1
QGIS i WMS stworzony w Mapserver
Stworzyłem WMS za pomocą MapServer CGI. Prosty, śmiga ładnie ale tylko na stronie WWW. Jestem na 90% pewny, że dobrze skonfigurowałem w Mapserver (konkretnie w pliku .map) wszystko co dotyczyło WMS. Oczywiście wsio na podstawie dokumentacji MapServera.
Jednak istnieje problem z wyświetlaniem warstw WMS w QGIS. Ładnie łącze się ze stworzonym WMS jednak warstwy się nie pokazują mimo, iż pojawiają się na liście warstw. WMS jest w wersji 1.3.0 i obsługuje EPSG 2180 (czyli układ 1992). Oczywiście taki układ przyjąłem dla projektu, a jednostki ustawiłem na metry. Nie mam pojęcia co jest nie tak. W ramach kombinatorstwa zmieniłem z PUWG1992 na WGS84 na wyjściu z WMS. Zmiany układu dokonałem też w projekcie, analogicznie na WGS84 i stopnie dziesiętne.
I teraz trochę dziwna dla mnie sprawa... Oprócz danych wektorowych opracowanych przeze mnie, mój WMS pobiera dane z innego WMSa (NASA). Ta warstwa z NASA wyświetla się (w Qgis) za pośrednictwem mojego WMS bez problemowo. Co więcej, jeżeli podczas wyboru warstw z mojego WMS wybiorę żeby z warstwą WMS (NASA) wyświetlała się też warstwa utworzona przeze mnie to nagle ta warstwa się pojawia i wyświetla się w dobrym odwzorowaniu i ogólnie wsio ok. ale jak chcę wyświetlić ją samą, bez warstwy WMS NASA to już nie chce.
Mam nadzieję że w miarę jasno opisałem problem....zresztą zawsze mogę się poprawić na życzenie Smile


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Wykorzystanie Quantum GIS + MapServer banan8 3 19 201 28-12-2010, 13:11
Ostatni post: tomiecz

Skocz do: