Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
Problem z zaznaczeniem wielu obiektów / warstwa wektorowa POINT z bazy danych MySQL
16-05-2018, 10:15,
#1
Problem z zaznaczeniem wielu obiektów / warstwa wektorowa POINT z bazy danych MySQL
Cześć,

Nie wiem o co chodzi pomocy Smile

Mam warstwę wektorową pobieraną z bazy MySQL, tam jest robiny POINT z wartości X,Y (WGS)

+-----------------+-------------------+------+-----+---------+-------+

| Field           | Type              | Null | Key | Default | Extra |
+-----------------+-------------------+------+-----+---------+-------+
| id              | int(11) unsigned  | NO   |     | NULL    |       |
| point           | geometry          | YES  |     | NULL    |       |
| TERC            | varchar(10)       | NO   |     | NULL    |       |
| SIMC            | varchar(10)       | NO   |     | NULL    |       |
| ULIC            | varchar(10)       | NO   |     | NULL    |       |
| ulica           | varchar(50)       | NO   |     | NULL    |       |
| numer_budynku   | varchar(10)       | NO   |     | NULL    |       |
| X               | varchar(11)       | YES  |     | NULL    |       |
| Y               | varchar(11)       | YES  |     | NULL    |       |
+-----------------+-------------------+------+-----+---------+-------+

Wyświetla wszystko dobrze! 
Działa!
Jak zaznaczam jeden punkt , pokazują mi się poprawnie atrybuty tego obiektu "wynik identyfikacji"
Jak Klikam w "w tabeli atrybutów" też mi się zaznacza dobry punkt.

Problem jest taki , że

Jak zaznaczam więcej punktów "zaznacz obiekty" zaznaczają mi się zawsze wiersze od góry tabeli.

albo jakoś losowo - nie widzę reguły.

Ale nie te które faktycznie zaznaczam.

Nie wiem kompletnie o co chodzi, myślę że jakoś zaburzona jest identyfikacja w "tabeli atrybutów"
Nie mam pomysłu.

Dotyczy QGIS 2.18 (używam) ale i 3>

Pozdrawiam
Janek.
16-05-2018, 10:23,
#2
RE: Problem z zaznaczeniem wielu obiektów / warstwa wektorowa POINT z bazy danych MySQL
Jak klikam w "tabli atrybutów" jeden rekord , zaznacza mi się na mapie na żółto - ale nie ten co trzeba.
16-05-2018, 22:55,
#3
RE: Problem z zaznaczeniem wielu obiektów / warstwa wektorowa POINT z bazy danych MySQL
Czy dla kolumny id masz założony PRIMARY KEY (Klucz główny) ?
17-05-2018, 08:33,
#4
RE: Problem z zaznaczeniem wielu obiektów / warstwa wektorowa POINT z bazy danych MySQL
adrboc,
Własnie!

Używałem view i z natury rzeczy nie ma tam takiego indexu.
Zmaterializowałem dane, przerobiłem na 'table' z PK i śmiga !

QGIS , musi mieć deklaracje PK.

Pomogłeś! , bardzo dziękuje.

Pozdrawiam!


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  MYSQL columna ID Primary Key behemot 1 329 30-07-2018, 11:34
Ostatni post: behemot

Skocz do: