Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
Problem z tabelą atrybutów (powiaty do gmin)
10-03-2023, 22:45,
#1
Problem z tabelą atrybutów (powiaty do gmin)
Cześć,
Chciałbym wyeksportować nazwy gmin (wraz z numerem TERYT) oraz powiatów w Polsce do excela. Ściągnąłem listę gmin oraz listę powiatów. Chciałbym przyłączyć nazwy powiatów do odpowiadających im gmin. Teoretycznie jest to proste, bo pierwsze cztery cyfry w kodzie TERYT gminy to kod TERYT powiatu, więc wystarczyłoby uciąć poleceniem LEFT 4 cyfry z Terytu gminy i to jest wspólna kolumna. Problem pojawia się wtedy, gdy Teryt gminy zaczyna się od zera (a jest tak w gminach i powiatach leżących w woj. dolnośląskim, kujawsko-pomorskim, lubelskim i lubuskim), bo wtedy po wykorzystaniu polecenia LEFT to zero z przodu znika i w nowo utworzonej kolumnie zamiast 4 cyfr są 3 cyfry i nie wiem jak to zmienić.
Przykład: TERYT gminy: 020102_1
TERYT powiatu: 0201

Stosując polecenie LEFT(TERYT, 4) - zamiast poprawnego wyniku (0201) powstaje 201

Próbowałem eksportować dane do excela i w excelu za pomocą polecenia "tekst" dodawać to jedno zero (i w excelu jest wszystko ok), ale po wczytaniu tych edytowanych danych z powrotem do Qgisa, znów Qgis ucina to pierwsze zero. Jak to zmienić?
12-03-2023, 18:09,
#2
RE: Problem z tabelą atrybutów (powiaty do gmin)
Robisz dobrze, tylko pole do którego mają być wgrane nowe dane musi być typu tekstowego, a zapewne masz ustawione do pola liczbowego. Nie ma takiej liczby jak "03" więc z automatu jest zamieniania na "3". Spróbuj i daj znać
12-03-2023, 22:40,
#3
RE: Problem z tabelą atrybutów (powiaty do gmin)
Teraz działa bardzo dobrze, dzięki wielkie. Rozwiązanie takie proste, a ja na to nie wpadłem...


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Tabela atrybutów agmar_geo 1 10 372 21-03-2014, 16:53
Ostatni post: robert

Skocz do: