Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
Co się stało z układami współrzędnych w QGIS 1.6?
30-08-2010, 09:27, (Ten post był ostatnio modyfikowany: 30-08-2010, 09:44 {2} przez tomalos.)
#1
Co się stało z układami współrzędnych w QGIS 1.6?
Bawię się ostatnio wersją QGIS Trunk, po ostatniej aktualizacji mam z nią jednak poważne problemy i jeśli szybko nie znajdę rozwiązania wracam do 1.5.

Wygląda to tak, po ostatniej aktualizacji do wersji 1.6.0-svn14132 QGIS nie może odszukać układów współrzędnych (przynajmniej takie mam wrażenie). Jako opiekuna tej wersji system (Ubuntu) podaje Quantum GIS developers. Przy wczytywaniu jakiejkolwiek warstwy QGIS sygnalizuje błąd:

Cytat:Error
Could not open CRS database /usr/share/qgis/resources/srs.db<br>Error(14): unable to open database file

Podczas utruchamiania programu również wtyczka OpenLayer się buntuje, że nie ma odwzorowania:

Cytat:OpenLayers plugin zgłasza błąd "Could not set Google projection!"

Poza tym podczas użycia narzędzia Informacje o obiekcie program się wiesza (ale się nie zamyka) pochłaniając całą moc obliczeniową procesora (wcześniej w 100% nie wykorzystywał wszystkich jąder procesora nawet przy wykonywaniu kilkugodzinnych operacji). Po wymuszeniu zamknięcia programu okno QGISa się zamyka a obciążenie komputera nie spada, nadal jest uruchomiony proces qgis.bin, który trzeba zakończyć ręcznie. Problem występuje zarówno na Ubuntu Karmic jak i Lucid, na komputerach 32 i 64 bit. Czy ktoś coś o tym wie?
Otwarcie QGIS przez terminal nie zwraca dodatkowych komunikatów o błędach, właściwie to w terminalu nie ma żadnych informacji o błędach. Gdzie jeszcze można szukać takich informacji?

--------------------------------------------

Już nieaktualne! Rozpędziłem się trochę z tym wątkiem. Pobrałem najnowsze aktualizacje i wygląda na to, że w weekend programiści to naprawili.
30-08-2010, 10:07,
#2
RE: Co się stało z układami współrzędnych w QGIS 1.6?
Trunk, jak to Trunk, raz będzie stabilny, a raz mniej. Może akurat w tej rewizji był jakiś bug, który w następnej został poprawiony i nieszczęściem ta poszła do pakowania. Ja bym poczekał na kolejnego builda (teraz mamy już r 14169) i dopiero się przejmował.

Ten plik srs.db jest tam, czy go brakuje? Wieszanie bardzo dziwne. Co do informacji, to jak program się tylko zapętla, a nie wysypuje, to nie bardzo jest co wyświetlić...
30-08-2010, 11:03,
#3
RE: Co się stało z układami współrzędnych w QGIS 1.6?
Cytat:Ten plik srs.db jest tam, czy go brakuje?
Zaktualizowałem do najnowszej wersji i nie zdążyłem sprawdzić.
30-08-2010, 11:07,
#4
RE: Co się stało z układami współrzędnych w QGIS 1.6?
o, czyli to już działa?
30-08-2010, 15:06,
#5
RE: Co się stało z układami współrzędnych w QGIS 1.6?
Tak, działa Smile
30-08-2010, 21:16,
#6
RE: Co się stało z układami współrzędnych w QGIS 1.6?
Aaaa, nie zauważyłem dopisku Smile Dlatego lepiej jest samemu kompilować Trunka, bo jak coś się posypie, to zazwyczaj po chwili jest poprawka, a poza tym zawsze można się cofnąć do poprzedniej rewizji Smile


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
Question co się stało z funkcją geomwithin gazownik 3 538 06-09-2022, 20:30
Ostatni post: xmaziax
  Korekta przy transformacji miedzy układami sebaq 11 53 743 02-04-2013, 09:21
Ostatni post: sebaq
  Konwersja między układami Zyta 8 40 430 02-07-2010, 18:56
Ostatni post: georobot

Skocz do: