Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
Problem z mapą dynamiczną
10-03-2011, 07:50 PM
Post: #1
Problem z mapą dynamiczną
Witam

Jakiś czas temu zabrałem się za aplikację Mapserver, ale dość szybko utknąłem. Mianowicie mam problem z wyświetleniem mapy dynamicznej = browse. W źródle strony pokazuje błąd 404 czyli nie może znaleźć pliku. Wyświetla tylko szablon ze "złamanym obrazkiem". Ścieżki zmieniałem tysiące razy.

Cytat:MAP #początek pliku
WEB
TEMPLATE 'tut.html'
IMAGEPATH "E:htdocs mp"
IMAGEURL "htdocs mp"

END #web
IMAGETYPE "PNG"
EXTENT 16.9883 54.5091 17.7005 55.1102
SIZE 600 400
SHAPEPATH "leba"
IMAGECOLOR 0 0 0
FONTSET "E:htdocsfontyfonts.list"

LAYER
NAME "leba"
DATA "htdocslebaleba.shp"
STATUS DEFAULT
TYPE POLYGON
LABELITEM "nazwa"
CLASSITEM "typ"

CLASS
LABEL
FONT "arial"
TYPE truetype
SIZE 10
POSITION LC
PARTIALS FALSE
COLOR 100 170 160
OUTLINECOLOR 0 0 0
END #Lable
EXPRESSION "jezioro"
NAME "jezioro"
STYLE
COLOR 255 0 120
OUTLINECOLOR 170 0 120
END#style
END#class1
CLASS
LABEL
FONT "arial"
TYPE truetype
SIZE 10
POSITION LC
PARTIALS FALSE
COLOR 0 0 150
OUTLINECOLOR 0 0 0
END#label
NAME "morze"
STYLE
COLOR 0 0 120
OUTLINECOLOR 0 0 0
END#style
EXPRESSION "morze"
END#class2
END#layer

LAYER
NAME "sat"
DATA "E:htdocslebasat7422.tif"
STATUS DEFAULT
TYPE RASTER
OFFSITE 255 255 206

END #style
END #class
END #layer
END #map

Natomiast mapa statyczna działa bez problemu.
Szablon wziąłem z tutoriala mapservera.
Cytat:<!-- MapServer Template -->
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2">
<title>szablon</title>
</head>
<body BGCOLOR="white" TEXT="#000000" LINK="#0000FF" VLINK="#0000FF">
<table width="601" align="center" border="0">
<tr>
<td width="593" align=center>
<table cellpadding=10 >
<tr>
<td align=left><img src="/mapserver-tutorial/img/powered_mapserver.jpg"></td>
<td align=left><h3>MAPServer (using templates for
navigation controls)</h3></td>
</tr>
</table>
<br>
<!-- START OF MAPSERVER FORM -->
<form name="mapserv" method="GET" action="/cgi-bin/mapserv.exe">
<!-- HIDDEN MAPSERVER CGI VARIABLES -->
<input type="hidden" name="map" value="[map]">
<input type="hidden" name="imgext" value="[mapext]">
<input type="hidden" name="layers" value="[layers]">

<tr>
<td>
<table width="400" border="0">
<tr>
<td bgcolor="#425b7a" width="40%" >
<!-- SPECIFY MAP MODE -->
<div align="center"><font color=white>cos: </font>
<select name="mode">
<option value="browse">typ (browse)</option>
<option value="map">typ (map)</option>
</select>
</div>
</td>
<td bgcolor="#425b7a" width="15%">
<!-- FORM SUBMIT BUTTON -->
<div align="center">
<input type="submit" name="submit" value="(submit)">
</div>
</td>
<td bgcolor="#425b7a" width="45%">
<!-- ZOOM/PAN CONTROLS -->
<div align="center"><font color=white>Skala:</font>
<select name="zoom">
<option value="4" [zoom_4_select]>4x (zoom-in)</option>
<option value="3" [zoom_3_select]>1x (zoom-in)</option>
<option value="2" [zoom_2_select]>2x (zoom-in)</option>
<option value="1" [zoom_1_select]> (pan)</option>
<option value="-2" [zoom_-2_select]>2x (zoom-out)</option>
<option value="-3" [zoom_-3_select]>3x (zoom-out)</option>
<option value="-4" [zoom_-4_select]>4x (zoom-out)</option>
</select>
</div>
</td>
</tr>
<tr>
<!-- DISPLAY THE MAPSERVER-CREATED MAP IMAGE -->
<td colspan="3" align="right" valign="top">
<input type="image" name="img" src="[img]"
width="600" height="400" border="1">
</td>
</tr>
</table>
</td>
</tr>
</form>
</table>
<br>
<hr noshade width="80%" size="1" align="center">

</body>
</html>
Wie ktoś dlaczego tak się dzieje??
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
13-06-2011, 08:30 AM
Post: #2
RE: Problem z mapą dynamiczną
Proponuję zamiast
WEB
TEMPLATE 'tut.html'
IMAGEPATH "E:htdocs mp"
IMAGEURL "htdocs mp"
END

Wpisać
WEB
TEMPLATE 'tut.html'
IMAGEPATH "htdocs mp"
IMAGEURL "htdocs mp" # lub ewentualnie" mp"
END

Powinno ruszyć. Rozumiem, że pracujesz na Windowsie
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
Odpowiedz 


Skocz do: