Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
warstwa z bazy postgis
01-06-2011, 07:00 PM
Post: #1
warstwa z bazy postgis
Utworzyłem WMS, który ma ciągnąć dane z bazy Postgis. QGIS widzi WMS, ale jak chcę dodać warstwę do projektu to:

Cytat:(Nie zwrócono kodu błędu)
Dostarczyciel WMS przekazuje również:
msWMSLoadGetMapParams(): WMS server error. Image size out of range, WIDTH and HEIGHT must be between 1 and 2048 pixels.
Nie mogę wygooglać odpowiedzi...

oto mapfile
Kod:
MAP # poczatek pliku

IMAGETYPE          PNG
EXTENT            654627 509312 660545 514218
SIZE               400 400
IMAGECOLOR         0 0 0

WEB

    METADATA

    "wms_title" "test"
    "wms_onlineresource" "http://geoforest.org/mapserver/cgi-bin/mapserv?map=/home/mdrozdz/www/klembow.map&"
    END # end METADATA


END # end WEB

PROJECTION
   "init=epsg:2180"
END


LAYER
  NAME "test"
  STATUS ON
  TYPE POLYGON
  MAXSCALE 100000
  CONNECTIONTYPE POSTGIS
  CONNECTION "user=### dbname=### host=### password=###"
  DATA "the_geom from dzialki using srid=2180"
  CLASS
     STYLE
        
        COLOR            0 170 0
        
        
      END #Koniec obiektu STYLE
      
    
  END

METADATA
            WMS_TITLE             "test"
            WMS_ABSTRACT         "test"

            END # end metadata

        PROJECTION
           "init=epsg:2180"
        END # end projection

END




END #Koniec obiektu MAP
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
01-06-2011, 08:00 PM (Ten post był ostatnio modyfikowany: 01-06-2011 08:01 PM przez borys.)
Post: #2
RE: warstwa z bazy postgis
A Ty czemu nie na slajdach? Podobno jest świeża szarlotka Aliny Smile Zgodnie z tym, co pisze Doręczyciel, masz za duży monitor i próbujesz wyświetlić obraz większy niż 2048 pikseli wzdłuż któregoś boku. Musisz dodać w sekcji MAP parametr MAXSIZE 3000 czy ile tam potrzebujesz, żeby zmienić domyślne 2048.

Borys Jurgiel
Zespół Rozwojowy QGIS
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
01-06-2011, 10:17 PM
Post: #3
RE: warstwa z bazy postgis
W przyszłym tygodniu będę! Na jubileuszu
Monitor mam ten sam co zawsze i nawet jak ustawię na 100 000 to mi krzyczy, że coś nie tak...
Skąd ten parametr?
Tu nic o nim nie piszą: http://mapserver.org/input/vector/postgis.html
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
02-06-2011, 10:04 PM
Post: #4
RE: warstwa z bazy postgis
Walczę dalej!
Zainstalowałem sobie Postgis i Mapserver lokalnie na win 7 i chcę dodać zrobić ten sam myk... (co by wyeliminować jakieś błędne konfiguracje postgisa na hoście...)

tym razem po dodaniu WMS do QGIS:

Cytat:Odpowiedź: <?xml version='1.0' encoding="ISO-8859-1" standalone="no" ?>
<!DOCTYPE ServiceExceptionReport SYSTEM "http://schemas.opengis.net/wms/1.1.1/exception_1_1_1.dtd">
<ServiceExceptionReport version="1.1.1">
<ServiceException>
msWMSLoadGetMapParams(): WMS server error. Invalid values for BBOX.
</ServiceException>
</ServiceExceptionReport>
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
08-06-2011, 11:25 AM (Ten post był ostatnio modyfikowany: 08-06-2011 11:27 AM przez borys.)
Post: #5
RE: warstwa z bazy postgis
(02-06-2011 10:04 PM)Odoakr napisał(a):  msWMSLoadGetMapParams(): WMS server error. Invalid values for BBOX.

No a coś więcej? Smile Jakiego BBOXa i układu żądasz i jak to się ma do danych na serwerze?

Borys Jurgiel
Zespół Rozwojowy QGIS
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
Odpowiedz 


Skocz do: