Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu 9.10 i PostgreSQL / PostGIS
19-04-2010, 01:31 PM (Ten post był ostatnio modyfikowany: 19-04-2010 01:32 PM przez tomalos.)
Post: #1
Ubunu 9.10 i PostgreSQL / PostGIS
Chciałem stworzyć bazę danych PostGIS a następnie załadować do niej pliki .shp. W celu instalacji PostgreSQL postępowałem zgodnie z tym opisem, wszystko chyba się udało. Następnie zgodnie z kolejnym opisem zainstalowałem i próbowałem skonfigurować PostGIS i to już niestety mi się nie udało. Zainstalowałem postgis oraz postgresql-8.4-postgis - wersja 8.4 bo taka najnowsza była w Synapticu. Zmieniłem użytkownika na postgres (su postgres), utworzyłem próbną bazę (createdb mojabaza), dodałem proceduralny język PL/pgSQL (createlang plpgsql mojabaza), chciałem utworzyć potrzebne tabele (psql -d mojabaza -f /usr/share/postgresql-8.4-postgis/lwpostgis.sql) i wywaliło mi błąd, że nie ma pliku /usr/share/postgresql-8.4-postgis/lwpostgis.sql. Zrobiłem więc wszystko jeszcze raz tym razem dla wersji postgresql-8.3-postgis. tym razem terminal wywala mi coś takiego:
psql:/usr/share/postgresql-8.3-postgis/lwpostgis.sql:4028: ERROR: current transaction is aborted, commands ignored until end of transaction block
psql:/usr/share/postgresql-8.3-postgis/lwpostgis.sql:4034: ERROR: current transaction is aborted, commands ignored until end of transaction block
psql:/usr/share/postgresql-8.3-postgis/lwpostgis.sql:4040: ERROR: current transaction is aborted, commands ignored until end of transaction block
psql:/usr/share/postgresql-8.3-postgis/lwpostgis.sql:4046: ERROR: current transaction is aborted, commands ignored until end of transaction block
(...)
Od razu się przyznam, że nie maiłem dotychczas do czynienia z bazami danych.
Jest ktoś skłonnym pomóc mi - laikowi, tak, żebym zrozumiał?
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
19-04-2010, 07:39 PM
Post: #2
RE: Ubunu 9.10 i PostgreSQL / PostGIS
W Karmicu postgis 8.4 jest w nieco innej lokalizacji:

/usr/share/postgresql/8.4/contrib/postgis.sql
/usr/share/postgresql/8.4/contrib/spatial_ref_sys.sql

Reszta tak samo jak w opisie. Warto w Synapticu we właściwościach zainstalowanego pakietu zerknąć, jakie w nim są pliki i gdzie się wypakowały, bo różnie to bywa w różnych dystrybucjach.

A te błędy w 8.3 znaczą, że jakiś wcześniejszy błąd zablokował transakcję, trza ją zamknąć i zacząć od nowa.

Z tekstu nie wynika, czy postgisa 8.3 instalowałeś na postgresie 8.3, czy wciąż na 8.4 - one nie sią kompatybilne na krzyż.

Borys Jurgiel
Zespół Rozwojowy QGIS
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
20-04-2010, 08:18 AM
Post: #3
RE: Ubunu 9.10 i PostgreSQL / PostGIS
(19-04-2010 07:39 PM)borys napisał(a):  W Karmicu postgis 8.4 jest w nieco innej lokalizacji:

/usr/share/postgresql/8.4/contrib/postgis.sql
/usr/share/postgresql/8.4/contrib/spatial_ref_sys.sql

Reszta tak samo jak w opisie.

Dzięki, wszystko działa jak trzeba....
...póki co bo nie wykluczam, że pojawią się jeszcze pytania jak coś zepsuję albo czegoś nie będę wiedział Rolleyes
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
Odpowiedz 


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  problem z PostgreSQL/postgis na Debian Wheezy Bles 2 15 203 15-02-2016 10:54 AM
Ostatni post: Bles
  Ubuntu 14.04.3 LTS Saalomon 15 15 871 30-11-2015 07:16 PM
Ostatni post: Binko

Skocz do: