Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
problem z otworzeniem mapy
27-12-2010, 03:44 PM
Post: #1
problem z otworzeniem mapy
Witam. Niestety nie znam się na WEBGISie ani na htmlu, a przebrnięcie mapservera jak na razie okazuje się ponad moje siły. Mam problem z otworzeniem mapy zapisanej przez wtyczkę MapserverExport. Po zakończeniu zapisywania mapy pojawia się komunikat:
Starting
Wrote map section
Wrote projection section
Wrote output format section
Wrote legend section
Wrote web section
Wrote map layers
Map file completed for C:/projektmapserv.qgs
Map file saved as C:/projektmapserv.map

> If this mapfile is accessible by your mapserver, you
should be able to see the capabilities by firing this url:
http://localhost/cgi-bin/mapserv.exe?MAP=C:/projektmapserv.map&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetCapabilities

> if this mapfile is accessible by your mapserver, you
should be able to see a map by firing this url:
http://localhost/cgi-bin/mapserv.exe?MAP=C:/projektmapserv.map&LAYERS=ALL&MODE=MAP

Sprawdzając mapę zgodnie z podanymi adresami pojawił się komunikat:

loadSymbolSet(): Unable to access file. (./symbols/symbols.txt)

Po usunięciu ścieżki do symboli (zgodnie z zaleceniem z innego tematu)w pliku i przeładowaniu strony pojawia się komunikat:

msLoadMap(): Unknown identifier. First token must be MAP, this doesn't look like a mapfile.

Niezależnie od tego czy początek pliku wygląda tak jak go wtyczka stworzyła czyli:

# Map file created from QGIS project file C:/projektmapserv.qgs
# Edit this file to customize for your map interface
# (Created with PyQgis MapServer Export plugin)
MAP
NAME "QGIS-MAP"
# Map image size
SIZE 512 256
UNITS meters

EXTENT -2.638468 -0.582631 -0.088234 1.106715
FONTSET './fonts/fonts.txt'
SYMBOLSET '.'
PROJECTION

Czy po usunięciu początku:

MAP
NAME "QGIS-MAP"
# Map image size
SIZE 512 256
UNITS meters

EXTENT -2.638468 -0.582631 -0.088234 1.106715
FONTSET './fonts/fonts.txt'
SYMBOLSET '.'
PROJECTION

Czy ktoś wie co może być nie tak?
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
27-12-2010, 09:48 PM
Post: #2
RE: problem z otworzeniem mapy
Ta wtyczka nie tworzy plików z definicją symboli. Jak ją testowałem to stworzyłem sobie taki prosty plik na podstawie dokumentacji MapServera i poszło. Przy eksporcie warstwy punktowej wymagał, o ile dobrze pamiętam, symbolu 'circle'. Przy warstwach liniowych chyba nie wymaga definicji symboli.
Jeśli chodzi o czcionki to trzeba stworzyć plik tekstowy ze spisem czcionek. Format też opisany w dokumentacji.
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
29-12-2010, 02:32 PM
Post: #3
RE: problem z otworzeniem mapy
Czy mógłbyś podać jakieś bardziej konkretne namiary? Bo szczerze mówiąc to nie mam pojęcia o co chodzi. Odniesienia do definicji symboli i czcionek usunąłem i program już o nie nie pyta. Problemem jest komunikat:
msLoadMap(): Unknown identifier. First token must be MAP, this doesn't look like a mapfile.
I nie mam pojęcia jak to działa ponieważ tą samą powierzchniową warstwę wektorową pobraną z internetu, którą mapserver wyświetla zapisaną w układzie 84, w innych polskich układach:1965,1992 już nie i pojawia się ten właśnie komunikat. Z drugiej strony stworzona przeze mnie powierzchniowa warstwa wektorowa nie wyświetla się nawet w układzie 84. Może ktoś wie jak to rozwiązać?
Znajdź wszystkie posty użytkownika
Zacytuj ten post w odpowiedzi
Odpowiedz 


Skocz do: